`
zsybupt
  • 浏览: 41458 次
  • 性别: Icon_minigender_1
社区版块
存档分类
最新评论

boj 447

    博客分类:
  • oj
 
阅读更多

Description
Let’s play a stone removing game.

Initially, n stones are arranged on a circle and numbered 1, …, n clockwise (Figure 1). You are also given two numbers k and m. From this state, remove stones one by one following the rules explained below, until only one remains. In step 1, remove stone m. In step 2, locate the k-th next stone clockwise from m and remove it. In subsequent steps, start from the slot of the stone removed in the last step, make k hops clockwise on the remaining stones and remove the one you reach. In other words, skip (k − 1) remaining stones clockwise and remove the next one. Repeat this until only one stone is left and answer its number. For example, the answer for the case n = 8, k = 5, m = 3 is 1, as shown in Figure 1.



Initial state: Eight stones are arranged on a circle.

Step 1: Stone 3 is removed since m = 3.

Step 2: You start from the slot that was occupied by stone 3. You skip four stones 4, 5, 6 and 7 (since k = 5), and remove the next one, which is 8.

Step 3: You skip stones 1, 2, 4 and 5, and thus remove 6. Note that you only count stones that are still on the circle and ignore those already removed. Stone 3 is ignored in this case.

Steps 4–7: You continue until only one stone is left. Notice that in later steps when only a few stones remain, the same stone may be skipped multiple times. For example, stones 1 and 4 are skipped twice in step 7.

Final State: Finally, only one stone, 1, is on the circle. This is the final state, so the answer is 1.



Input
The input consists of multiple datasets each of which is formatted as follows.

n k m

The last dataset is followed by a line containing three zeros. Numbers in a line are separated by a single space. A dataset satisfies the following conditions.

2 ≤ n ≤ 10000, 1 ≤ k ≤ 10000, 1 ≤ m ≤ n

The number of datasets is less than 100.


Output
For each dataset, output a line containing the stone number left in the final state. No extra characters such as spaces should appear in the output.


Sample Input

8 5 3
100 9999 98
10000 10000 10000
0 0 0


Sample Output

1
93
2019


Source
tokyo 2007

 

约瑟夫环问题,n个人编号1~n围成一圈报数,报到m的人出列,循环,找最后剩下的人编号。

初始序列为:1,2,3,4,5...m-1,m,m+1...n

去掉一个人后:1,2,3,4,5...m-1,m+1...n

m+1,m+2...n...1,2,3,...m-1

做如下变换:

m+1->1

m+2->2

....

....

m-1->n-1

则序列为:1,2,3,4,...n-1

变成了n-1个人报数的问题,递归求解,设n-1个人的解为x,易得在原始序列中的解为(x+m)%n(注意模为0的情况,即解为n);

此题要注意的就是第一次是报m,后面全部报k

代码:

#include<iostream>
using namespace std;
int main()
{
	int n,k,m;
	scanf("%d %d %d",&n,&k,&m);
	while(!(n==0&&m==0&&k==0))
	{
		int tmp = 1;
		for(int i =2;i<n;i++)
		{
			tmp = (tmp+k)%i;
			if(tmp==0)
				tmp = i;
		}
		tmp = (tmp+m)%n;
		if(tmp==0)
			tmp = n;
		printf("%d\n",tmp);
		scanf("%d %d %d",&n,&k,&m);
	}
}

 

分享到:
评论

相关推荐

    BOJ题目1023. Ancient Keyboard 源代码

    BOJ的题目1023. Ancient Keyboard解法 源代码

    boj 0809复试模拟题答案

    boj 上08 09 年复试模拟题的答案

    JAVA_BOJ

    JAVA_BOJ

    boj:算法

    boj:算法

    Algorithm-BOJ.zip

    Algorithm-BOJ.zip,BekJon在线法官(Java,Kotlin,SWIFT)和PS路线图,算法是为计算机程序高效、彻底地完成任务而创建的一组详细的准则。

    BOJ

    BOJ

    Algorithm-BOJ-PSJ.zip

    Algorithm-BOJ-PSJ.zip,Baykon在线判断JAVA问题解决方法(第二章),算法是为计算机程序高效、彻底地完成任务而创建的一组详细的准则。

    Algorithm-BOJ-AutoCommit.zip

    Algorithm-BOJ-AutoCommit.zip,当您解决baekjoon online judge的问题时,它会自动提交并推送到远程存储库。,算法是为计算机程序高效、彻底地完成任务而创建的一组详细的准则。

    Algorithm-boj-auto-submit.zip

    Algorithm-boj-auto-submit.zip,日本央行cli提交脚本,算法是为计算机程序高效、彻底地完成任务而创建的一组详细的准则。

    Python库 | boj-0.0.1.tar.gz

    资源分类:Python库 所属语言:Python 资源全名:boj-0.0.1.tar.gz 资源来源:官方 安装方法:https://lanzao.blog.csdn.net/article/details/101784059

    Boj Coloring Book-crx插件

    通过这本图画书展示您的创造力,其中包括Boj和朋友。 一本有趣的,全数字化且可重复使用的着色书,可用于 通过这本图画书展示您的创造力,其中包括Boj和朋友。 一本有趣的全数字可重复使用的图画书,专为孩子,父母...

    boj.kr:解决boj.kr的问题

    解决问题 Boj.kr

    PS_BOJ:BOJ문제풀이

    欢迎来到PS_BOJ 이곳은... J이한BOJ문제들의AC코드들이입니다。 안내 :check_mark: C ++ Python으로풀이합니다。 :check_mark: ++ C ++풀이하며 long long 필요하거나으으으으으으으으으끔씩만끔씩만끔씩만끔씩만...

    BOJ:日本央行

    BOJ:日本央行

Global site tag (gtag.js) - Google Analytics